Sunday, January 25, 2009

 

Something else - Logitech Z680 mod for lower Bass output

NOTE: If you execute the modification suggested below and you blow-up your set, you are on your own! I can give no warranties of any kind whatsoever...


Hi,

Ever since I can remember I have a Logitech Z680 5.1 audio set which I use to watch movies and listen to my music. It was the top-of-the-line audioset for PC's from Logitech way back, there's a follow-up top-set now: The Z5500.

This (Z680) is an audioset with integrated Dolby digital and DTS decoder and it has a remote as well. You can input audio using 3.5Inch jacks, but also using coaxial or optical cable. You can choose from 3 input signals using the remote so I have the set connected to my stand-alone DVD player, but also to an old stand-alone audio set with CD player.

On the Z680 (one of) the downside(s) is that you cannot set the sub-woofers volume between 0 and 100% in small steps. Instead you can set 0%, and about 60-100%. On the Z5500 this limitation was removed BTW.

A lot of Z680 users including myself found that the 60% setting of the subwoofer is much too loud for most (living) rooms: Neighbours will complain about pictures falling of their walls, and the sound is not optimal for the user him (or her)self either.

So, I decided to take my set apart and modify it to be actually useable. I did two modifications: for one I added a RS232C interface in the hope I could (re)program the set some way. This RS232C interface was there on the board already, it just missed a few components placed though. Unfortunately the set's firmware does not have RS232C connectivity I found out.

The second modification, which is much more low-level, worked like a charm for me. I'll decribe that modification below.


Z680 Modification for a lower bass setting range.

The control POD of the Z680 has all digital inputs and the decoders. After all signal processing is done, the audio channels are converted to analog signals. These analog signals are then transferred to the bass speaker housing via the 15-pins thick black signal cable. In the bass speaker housing sits the analog amplifier that cranks up the signals so you can hear them from the speakers.

This means lowering the bass signal range can be simply done in the control pod at the exiting spot to the amplifier. I just located the signal wire for the sub-woofer speaker and took the wire loose. I then added a simple resistor network which divides the voltage to 1/3rd of the original level, and I attached the signal wire to the output of this divider. (The input of the divider is connected to where the wire was before.)

Since the voltage is now 1/3rd of the original, the current through the speaker is also at 1/3rd of the original which means output power is 1/3 * 1/3 = 1/9th of the original for a specific volume setting.

Now I can set the volume perfectly for my taste!


Photo's and a more detailed description.

Before you start make sure you have the following:
- a screwdriver
- a soldering iron
- soldering tin
- two resistors: one of 1k-Ohm and one of 2k-ohm or there about. 1/8th Watt versions will do nicely.

First, remove mains power and take the Z680 control POD loose from the set and any extra wires. Now remove the four black screws at the backside: make sure you removed them completely (take them out).
After you did this, you can gently pull of the front panel. Please note that a wire sits in between the front panel and the mainboard which will remain in the back part of the housing: so be gently indeed!





Picture 1:
The four black screws removed completely and the front cover removed gently.

You can see the dark-grey ribbon cable that connects the frontcover part with the POD's mainboard. Note that the light-grey ribbon cable will not be there in your case: this cable belongs to the RS232C modification I did.

This RS232C modification is not needed.


Once you have the situation as shown in picture 1 you can pull-off the dark-grey ribbon cable gently so the front-panel part nolonger bothers you while you do the modification. Please note the red wire in this cable as it denotes PIN1 of the connector (has a small triangle pointing at it on the mainboard if you look closely).


OK. Now you should gently pull the mainboard from the back part of the housing. Please note that at the backside of the mainboard there is a soldered connection to the thick black wire that normally connects to the Bass speaker's housing. Lift up the mainboard (including the other boards that sit on it) and gently turn it over.




Once you did that you'll be in the situation of Picture number 2 below.



Picture 2:
mainboard removed from back part of the housing. Again you can see the light-grey ribbon cable that belongs to my RS232C mod.




You'll not have that in your situation.














Below there's a closeup picture (3) of the situation in picture 2. Please note that the area of interest is where the black cable is soldered too. Please note the white characters printed on the board denoting (among others) the analog channels that are outputted on the respective wires:

+8 - +8V 'logic' power supply
G - 'logic' supply ground (return)
SB - ??
G - signal ground
RR - Rear Right speaker channel
RL - Read Left speaker channel
C - Center speaker channel
S - Subwoofer speaker channel - this signal we are going to modify
FR - Front Right speaker channel
FL - Front Left speaker channel
G - Signal ground
G - Signal ground
-18 - -18V analog power supply
G - analog power supply ground (return)
+18 - +18V analog power supply



Picture 3.
The area of interest, specificially the 'S' wire and the two G wires next to each other next to -18V.










Now flip the board so the other side faces up. Now Heat up your soldering iron and remove the brown wire that's soldered to the 'S' connection. Solder the 2K resistor (or 2 1k resistors in series as I did) to the S connection of the board leaving the other end free in the air.

Solder the 1k resistor with one side to the 'G' connection(s) next to the -18 signal as these G connections are closest by. Make ABSOLUTELY SURE you don't connect the -18 with the G next to it by accident! You'll probably blow-up the power supply in your set if you'd turn it on in such a case...

The other end of the 1K resistor needs to be soldered to the free end of the 2K resistor. Also connect the loose brown wire to this point. If you do it as neat as in picture 4 you can leave it as it is: it will fit nicely in the housing this way without making shortcuts.




Picture 4:
The board is flipped over showing the modification done to decrease the subwoofers power level.









The next picture shows the same modification from a different angle. Note BTW that I removed some of the white transparant 'glue' to be able to solder decently..




Picture 5:
Same spot viewed from a different angle.








OK, that's it!

Now put the control POD back together gently, keeping an eye on the modification and where you put the black cable. Re-attach the grey ribbon cable with the red wire at the same spot is was before. make sure all pins are indeed in the connector: no pins should be visible next to the connector's sides!

Gently put the top side on the backside: it should fit perfecly. If it does not, you probably made a mistake somewhere and you should just do it once more.
Put the four black screws in the backside and screw everything back together.


All set? Reconnect mains power and try your set. If it doesn't work remove mains power quickly and trace back all your steps to see if you made any mistakes, maybe it can be fixed.

If all is right it should work without a problem.


Variations:

You could also use other resistor values for more or less attenuation to fit your needs. I suggest to keep the values in the range from 1k to 10k Ohm and not much higher since the impedances of the circuitry around it are 'low' as well. It's said in the electronics that you get the best power-transfer if the impedances match..

Good luck!


Rudolf.

Comments:
Thank you so much for writing this up and sharing with us! I am going to try this soon because it's just too much bass. I need to first find those resisters first though. Fry's electronic? Circut city?
 
i have bough from Radio Shock 1/8-Watt 1K Carbon Film Resistors (5-Pack) used 3 of them in the same way as you did and the BASS its still the same, what am i doing wrong?
 
Hi Pop,
Can you make a photo of the setup you did?

The only thing I can think of is that you reversed the input and output wires on the resistor network..

Bye!

Rudolf.
 
Thanks for this post!

I just did this and it works fine.
 
What I did was putting a high value potentiometer (10kohm) in serie with the sub. I disconnected the red wire from the sub and put the potentiometer in between. After that you can adjust the volume with the potentiometer.
However, my feeling is that it is not good for the amplifier, because the normal impedance of the speaker is 4 to 8 ohm, and I now have 4000 ohm something.
Does this hurt my amp? It works though!

I have a spare control pod on which I can try your method.

However, putting the sub to a lower volume is not really the right way. I would like to insert a equalizer to lower the bass and maintain the higer frequenties.
That would be the best, there is just too much low bass.
 
Awesome! Followed your instructions yesterday and it works well. Been looking for a while for a way to fix this.

-Richard
 
Earlier I posted (under the name Joep Meloen) that I put a potentiometer in serie with the sub (speaker).
Last week after high volume my bass was gone. I thought I had fried my electronics. When I opened the sub I checked the potentiometer and came to the conclusion that I burned it!
When I removed it everything worked again.
Now I will try the solution mentioned above, though I sold the spare control pod.
 
Hey, thanks for the article on the bass reduction on the logitech 680. I was wondering if you know of a way I could "build" a line out into the system... I'd like to run it to a "real" sub since I run my logitech sub on low anyway and would like to have some boom in my movies!
PS ... do you have any other articles on the Log. 680? I'm I can't figure out how to search the site!

THanks!
Brian
 
Works perfectly !

Thanks you SO MUCH for this clever mod : the device comes useful again.

Loïc, Paris, France
 
Thanks!!! I haven't tried it yet, but I just moved into my new apartment and I finally get to set up my set again. My mom always complained about the sub and eventually made me disconnect it. Hopefully this works and my apartment manager doesn't do the same!
 
I can attest to the fact that this works. Bass volume is way down, but it was too loud on the lowest setting previously. Now I can actually fine tune the bass
 
I think I made a mistake along the way. Can someone help and offer advice?

I read the post wrong and connected the Ground to both the black G next the -18 and the G on the other side of the -18 (between the -18 and +18).

Now I'm not getting any sound output. I reset the wires and still the same result. Did I kill the subwoofer? Can I fix this somehow? The sub turns on and the POD is useable, just no audio output. Do one of these need to be replaced?
 
I think I made a mistake along the way. Can someone help and offer advice?

I read the post wrong and connected the Ground to both the black G next the -18 and the G on the other side of the -18 (between the -18 and +18).

Now I'm not getting any sound output. I reset the wires and still the same result. Did I kill the subwoofer? Can I fix this somehow? The sub turns on and the POD is useable, just no audio output. Do one of these need to be replaced?
 
I know this is an old post but if you are still following it can you explain why you are bridging the sub channel directly to the signal ground? I'm not an electronics expert but I would think what you would want is a single resistor in series with the sub signal output (S). Can you help me understand how this works?
 
Hey! First of all, thanks for figuring out the right wires. Now I have my Z680 for nearly 10 years and the bass was the only problem that prevented me from turning the volume really loud. I used 1k and 1k8 for now and I'm totally happy with it. The ~40% setting of bass is now the same as the lowest value before. So i can turn it much more down.

@Michiel Bruijn:
Thats nomal, your poti hat to burn down all the power of your amplifier, as you connected it to the amplified signal, not to the signal output from the pod.

If you want to use a poti, you'll have to connect in place of the 1k resistor. and it should have a range from 200Ω and 2kΩ or something around it. But not 10k!

So thanks again for this howto, im totally happy with the result :-)
 
After two years, I finally modified the sub with the suggested method.
It worked as a charm.
I also had to change a fuse inside so I did everything together.
Thanks again.

 
I just did this mod after owning the Z680s for 11 years... man I wish i'd done it earlier! It was easy and makes the sound quality sooo much better.
One tip: instead of 1k & 2k resistors, i started with double -- 2k & 4k. And even THAT is still on the loud side. I might even change to 4k & 8k.
 
update: now i'm at 1k and 4k resistors -- that's quieter, it's the ratio that matters not the values of the resistors. much better.
 
Are there also people who solved the white nois hiss sound produced by this set?
I really have to use some volume to not notice it. 5 years ago I sent a letter to logitech which resulted in a new sent control pod with exactly the same problem.
I already have firmware 1.1.2 which the other pod also had.
Is there a way to fitler the noise? Or is it caused by a lack of shielding inside the pod? I heared that z-5500 solved these problems
 
I have bought a used z-680 from a garage sale and the 15 pin cable has been desoldered from the control pod. I am looking for anyone that can give me the colors that correspond to the pads on the circuit board, inside the control pod. A few of the pictures here show me some but I would like to see all of them so I can get this system to work. Thank you i advance for help.
 
It is your lucky day today.
http://bruijn.nu/z-680
 
@Michiel Brujin - maybe you know this, or maybe not, but...you are THE MAN!! Thank you so very, very much my friend!
 
Post a Comment



<< Home

This page is powered by Blogger. Isn't yours?